Lesson 1: Introduction

Geography

Geography is the art and science of location!

Visual display can facilitate the analysis of location which is the spirit behind land use planning. Spatial Analysis is about analyzing change over space and time.

Maps can tell stories. The following map tells you about the location of Rabies instances.

Rabies Location
-no movement
Cartography is the art and science of making maps. In GIS, it is also the geographic presentation and visual interpretation of data.

A Map is a graphic representation of part of the earth’s surface.

- It conveys information easily and readily to a reader.
- A snap-shot of time.

A Coordinate System is used to reference map locations. Each point is recorded as a single x,y location.

Coordinates are numbers used to represent a location on a map usually in the form of longitude, latitude.

A projection is a mathematical conversion used to create a flat map sheet from a spherical surface. How to display a 3 dimensional object (the earth) on a 2 dimensional surface (your computer screen). A map will always have distortion because of

- Land mass shape
Here are some examples of projections

The Earth itself is a perfect map because there is no distortion of size, shape, distance and direction.

**GIS** stands for Geographic Information Systems- a technology for integrating maps and databases for visual appreciation and forward planning. There are many softwares of GIS.

**How Does MapInfo Professional Fit In?**

With MapInfo Professional you can start by using maps by performing the following tasks:

*Geocoding* -- Taking tabular data and giving it a geographical twist by assigning "objects to its records."

*Thematic Shading* -- Making tabular data easy for a reader to understand.

*Redistricting and Buffering* to help answer "Why" and "What If."
Lesson 2: Displaying Your Data

In this lesson you will complete the following:

- Open a map and display it in Map and Browser windows.
- Select particular records and Graph that data.
- Save your map display as a workspace and reopen the workspace.
- Use the Info tool to retrieve data.

Let's display a map table in both a Browser and Map window. Every MapInfo map is based on one or more tables of information. These tables contain geographic data that can be displayed on screen. The key to MapInfo is its ability to manipulate database information graphically in a Map window as well as in its tabular form in a Browser.

Viewing your Map

To open the States table in a Map window:

1. Start MapInfo.
2. Choose Open a Table in the Quick Start dialog.
3. Click Open.
4. Open the Lesson 2 folder, choose States and click Open.

A Map window displays with a map of the United States.

Map is now an option on the Menu bar. As the type of information you display changes, the top Menu bar may also display window-specific menu options.

Viewing Tabular Data
To see your data as text, in database/spreadsheet-like form you will use a Browser window.

To view the STATES table in a Browser window:

  o Choose Window > New Browser Window

The tabular information associated with the States table displays.

Glance at the menu at the top of the screen. Note that Browse has replaced Map as an option on the Menu bar.

  o Choose Window > Tile Windows so we can see both windows.

![Browser Window](image)

**Graphing and Selecting**

Let's create a graph that compares the population of several states. First, we'll make a selection from the States table, and choose states we wish to display in our graph.

1. Click the Select button ![Select Button](image) from the Main ButtonPad.
2. On the map click on three or four states.
3. You can hold down the `<SHIFT>` key and click to select more than one state.

As you click, notice that the small boxes in the left-hand column of the browser are also highlighted. You can also select records from the browser by clicking these boxes. Try it and click on a box to select a state from the Browser window. Regardless of where you make the selections, they display in both windows.

The selected states are now in a temporary table called Selection. The selected states can now be viewed separately from the rest of the States table.
To create a graph of your selected states:

1. Choose Window > New Graph Window.
2. Choose New Graph Window.
3. Select a chart type and template.
4. Click Next.
5. Choose Selection from the Table drop-down list.
6. Select Pop_1990 from the Fields Table drop-down list and press Add.

The graph dialog displays. Click OK to accept the options as they are.

The graph displays. Again, Graph replaces Browse as an option on the Menu bar. Keep in mind, you cannot make any changes to the underlying data through a Graph window. A graph is only a visual representation of tabular data.

The Graph window is now called Query1. Once you view a selection in a window, MapInfo renames it to QueryN. These queries will be numbered sequentially (i.e. Query1, Query2, and so on).

![Query1 Graph](image)

**Saving Time with Workspaces**

If you have spent a great deal of time labeling a map, opening tables and arranging your maps, browsers, and windows, you want MapInfo to remember exactly what you have on the screen. MapInfo allows you to save your place by creating a workspace. A workspace file contains a list of each file you have been using and the actions MapInfo needs to re-create your MapInfo desktop.
When you create a workspace you save the current window configuration. Before moving on to the next lesson, we will close all of our windows. However, since we may want to use this arrangement of windows in the future, we'll first save it as a workspace. The next time we want to access these windows, we can simply open the workspace. It is not necessary to rebuild maps every time you need them.

To save a workspace:

2. Name the file and click Save.
3. Choose File > Close All.

To reopen the workspace, choose File>Open Workspace. The files opens with the tables specified. You'll notice the selections are no longer saved.

Finding Information

Finally, we'll display some information about our states.

1. Click on the title bar of the Map window.
2. From the Main Toolbar, click the Info button.
3. Position the cursor over any state and click. MapInfo displays an Info tool window that contains the table information associated with the selected portion.

Congratulations, you are now ready to move on to the next lesson. Choose File Close > All to end this session.
Lesson 3: Mapping in Layers

You are now ready to practice using layers. Use layers to combine a variety of information into a single map and see the geographic relationships between data.

In this lesson, you’ll complete the following:

- Add and remove layers.
- Reorder layers.
- Make layers Editable and Selectable.
- Label objects in a layer.
- Experiment with seamless layers.

Managing Layers

You can use Layer Control to reorder, add and remove layers and change how and when layers are displayed. Let’s become acquainted with the Layer Control dialog. Let’s open a few maps first:

1. Choose File > Open Lesson 3 Folder. From the Open Table dialog you can select several files by clicking while holding down the Ctrl key. Click Statecap, States and US_hiway.
2. Click Open. A Map window displays with the three maps.

3. Choose Map > Layer Control. The Layer Control dialog displays.
Here you’ll see all of our layers in addition to the cosmetic layers. The Layer Control Check Boxes indicate the following:

<table>
<thead>
<tr>
<th>Check Box</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Visible" /> <strong>Visible</strong></td>
<td>By default, each layer is visible. To make a layer invisible, uncheck the Visible box.</td>
</tr>
<tr>
<td><img src="image" alt="Editable" /> <strong>Editable</strong></td>
<td>By default, each layer is not editable. This means you cannot make any changes to a layer’s map objects, such as reshaping, deleting, or adding new map objects. To modify a layer’s objects, check the Editable Check Box.</td>
</tr>
<tr>
<td><img src="image" alt="Selectable" /> <strong>Selectable</strong></td>
<td>By default, all layers are selectable. This means you can make selections in the map by using any one of the Select Buttons. To make a layer unselectable, uncheck this box.</td>
</tr>
<tr>
<td><img src="image" alt="Label" /> <strong>Label</strong></td>
<td>Check this box to turn automatic labels on for a layer. Modify automatic labels using the Label button.</td>
</tr>
</tbody>
</table>

**Reordering**

Right now we can clearly see all the layers. MapInfo attempts to logically place tables (as layers) in a Map window when opening tables or using Layer Control. When opening tables using the default option Automatic or adding layers though Layer Control, MapInfo looks at the type of map objects that are in the table. When MapInfo finds a layer containing mostly text, that layer will become the topmost layer. MapInfo will then place points layers underneath text, lines underneath points, and polygons underneath lines.
If we place the states layer on top of the highways layer, highways would disappear.

1. Select the States layer.
2. Click the Up button from the Reorder group and move it to the middle.
3. Click OK.

Notice the highways are no longer visible.

Removing a Layer

Let's remove a layer from the map. To remove the state capitals from our map:

1. Click the Layer Control button.
2. Select Statecap and click Remove from the Layers group.
3. Click Ok.

The map redisplays without the state capitals. To re-add the layer:

4. Click the Layer Control button and click Add from the layers group.

The Add Layer dialog displays.

5. Choose Statecap from the Add Layers list.
6. Click Add and click OK to close the Layer Control dialog box.

The map redraws showing the new layer you have added.

If you open two tables that contain the same type of map object, for example polygons, it will make the layer of the first table opened the bottom-most polygon layer. When the second table is opened containing polygons, its map layer will be placed on top of the first polygon layer. This behavior is true for other types of map objects.

Viewing an Entire Layer

To view all of the objects associated with a map layer within a Map window, use the View Entire Layer command.

- Choose Map > View Entire Layer.

The View Enter Layer dialog displays.
Choose the layer you wish to view from the View Entire Layer drop-down menu. Note: one of the options is All Layers.

Click OK.

**Changing the Appearance of a Layer**

At times you may want to change the appearance of a layer. It is possible to do this without permanently changing the table.

1. Choose Map > Layer Control. Open the Map menu.
2. Choose States.
3. Click Display.

The States Display Options dialog displays. In this dialog you can override the default style settings that determine how this layer displays in a Map window.

1. Check the Style Override check box to override the default style of a layer.
2. Click the Region Style button.

The Region Style dialog displays.

1. Click the Foreground drop-down menu from the Fill group box.
2. From the color palette, choose a new color.
3. Click OK to accept the color choice.
4. Click OK to accept the Display Options.
5. Click OK to close the Layer Control dialog.

**Zoom Layering**

Many layers that you use in your map windows may only be appropriate to use at certain zoom levels. Zoom layering allows you to have levels of detail displayed on a map that makes sense. The zoom layering feature allows you to specify a range of zoom levels for the layer to be displayed in.

In our map, if you zoom out too much, the Statecap layer will practically cover up the lower 48 states. We will set up the Map window so that the Statecap layer is only visible if the map is zoomed in to view 5,000 miles or less.

1. Choose Map > Layer Control.
2. Select the Statecap layer.
3. Click Display.
4. Check Display within Zoom Range.
5. Enter 5000 for the Max Zoom.
6. Click OK at the Display Options dialog box and click OK to close the Layer Control dialog box.

Now the capitals will only be displayed if the zoom level is 5,000 miles or less. Click the Zoom-out button and click on the map until the state capitals disappear.

**Duplicate Map Windows**

Once you have customized a view of your map, you may want to create a clone, or copy of the map window. In this way you might see two views of a map at the same time, perhaps choosing to zoom in for one view (to create an inset), while letting the other view provide the bigger picture.

- Choose Map > Clone Window

A duplicate map displays.

Congratulations, you have completed this lesson. Choose File > Close All before moving onto the next lesson.
Lesson 4: Opening Files

In this lesson, you'll learn how to open our sample Dc_cust file in some of the most common formats. These formats include DBF (database format), MS Access and MS Excel.

DBF files

Many software packages that work with information are capable of creating files in a format known as DBF. Open Dc_cust.dbf.

1. Choose File > Open Lesson 4 Folder.
2. From the List Files of Type box, choose dBase DBF.
3. Choose Dc_cust
4. Click Open.

DC customers display as tabular database information in a Browser window. Each row is referred to as a record and each column in the browser is referred to as a field. The Status Bar (in the bottom left corner of the screen) indicates how many records appear in the browser.

MS Access Databases

You can open and use Access Database tables in MapInfo.

1. Choose File > Open Table.
2. From the List Files of Type box choose Microsoft Access Database.
3. Choose Us_customer and click Open.
When an Access database consists of multiple tables, MapInfo will offer you the choice of opening one or more of the tables. A dialog box containing a list of the available tables displays:

1. Choose Us_Customer from the list.
2. Click OK.

The information displays in a browser.

MapInfo can read and write to data that is in Access Database format.

**ASCII files**

MI Pro also accepts delimited ASCII text files. A space, tab, comma, or another special character must be used to separate one field from another. MapInfo will prompt you to indicate what delimiter is being used and if the test's first line should be used as a column heading.

You can open a delimited ASCII text file in any text editor (such as Notepad or MS Write).

The following is a sample comma-delimited of our Dc_cust as an ASCII text file. The first line would be used as column headings in MapInfo.

"Lastname","Firstname","Address","Town","State","Zip","Department"

"PAWLUCK","BETH","3645 BANGOR ST SE","WASHINGTON","DC","20020","Production"
Excel spreadsheets

MapInfo supports both Excel and Lotus 1-2-3® spreadsheet formats. Let's open an Excel spreadsheet.

Before opening a spreadsheet in MapInfo, you need to know the answers to the following questions:

- What is the cell range of the data you wish to access? MapInfo needs to know what portion of the spreadsheet you wish to access. When defining the cell range, do not include column headings.
- Has the cell range of data been given a range name? You can refer to the range of data you wish to access with a name that is created in the spreadsheet software. If you create a range name for a range of cells, do not include column headings.
- Does the first row above the cell range of data contain column headings? Place column headings in the first row above the cell range of data.

To open our sample spreadsheet:

1. Choose File > Open Table.
2. In the List Files of Type box choose Microsoft Excel.
3. Choose Dc_Cust.
4. Click Open.

The Excel Information dialog displays with the Entire Worksheet specified as the range. Click OK.

The spreadsheet displays in a browser window.

Spreadsheets are read-only in MapInfo.

Congratulations, you have completed this lesson. Choose File > Close All to end the lesson. Let's move on to learn more about MI Professional!
Lesson 5: Putting It on the Map

Next, we'll place customers on the map. Before you can do this, each of your records must be assigned geographic coordinates.

In this lesson, you'll use our dBase file of our registered customers with our sample DC street map to display the locations of these customers on the street map. You will complete the following:

- Bring in a dBase format registrant database.
- Link the position of each data record to a map location.
- Display your data on the map.

First, we'll open the registrant database:

1. Choose File > Open Lesson 5 Folder. The Open Table dialog displays.
   - Choose dBase DBF from the Files of type drop-down list.
2. Click on the file Registr.dbf. Click Open.
3. The dBase DBF information dialog displays. Click OK.

The dBase database of registrants displays in the Browser window. Scroll through our customers and familiarize yourself with the data.

Assigning Coordinates

Before you can display your data on a map, you must first assign X and Y coordinates to its records. You assign X and Y coordinates by matching addresses in the Registr database with addresses in a street map table. Creating that match is called geocoding.

Next, we need to open the map on which we want to place the registrants:

1. Choose File > Open Table. Click on the file Dcwashs. Click Open.
2. Click the Map window’s maximize button. The Washington DC street map displays.

You now have a map to geocode (Dcwashs) and data to geocode to the map (Registr).

To begin automatic geocoding:

1. Choose Table > Geocode. The Geocode dialog displays.
2. Choose the options in the Geocode dialog as follows:
   - From the Geocode table drop-down list, choose Registr.
   - From the Using Column drop-down list, choose Address.
• Leave Boundary Column as none. From the Search drop-down list, choose Dcwashs.
• From the For Objects in Column drop-down list, choose Street.
• Click the Symbol button to change the symbol and its attributes.
• From the Symbol Style dialog select the arrow, the color red and point size of 18.
• Click OK to return to the Geocode dialog.

1. Click OK to start the process.
2. A second Geocode dialog displays allowing you to watch the geocoding process. Each database address is selected, and if possible, matched against streets in the Dcwashs table. In automatic geocoding, MapInfo geocodes each record where a match is found between Address and Street. It does not pause for unmatched records. We will handle unmatched records later, by using interactive geocoding. When automatic geocoding is finished, a summary of the results displays.
3. Click OK.

Next, we'll use interactive geocoding to match the 6 unmatched records.

1. Choose Table > Geocode. The Geocode dialog displays.
2. Choose the following options in the Geocode dialog:
   - From the Geocode table drop-down list, choose Registr.
   - From the Using Column drop-down list, choose Address.
   - From the Search table drop-down list, choose Dcwashs.
   - From the For Objects in column drop-down list, choose Street.
   - From the Mode options, choose Interactive.
   - Click OK to start the process.
MapInfo stops at the first non-matching address and shows you a list of alternative addresses or street number ranges, depending on the record in the Interactive Geocode dialog. Click OK for addresses you can recognize as correct matches such as St for Street. Occurrences of St. instead of St or using Ave. instead of Ave are the most common differences. Since street level accuracy is not that important for our purposes, choose to geocode those records to the first displayed selection.

Displaying your Data on the Map

Now, we’ll display the customers on the street map:

1. Click the title bar of the Dcwashes Map window to make it active.
2. From the Main Toolbar, click the Layer Control button 🌏. The Layer Control dialog displays.
3. From the Layer options, choose Add. The Add Layer dialog displays.
4. From the Add layer drop-down list, choose Registr and click Add. The Registr layer is placed just below the Cosmetic Layer. Click OK. The street map re-displays with each of the customers on the map represented by an arrow.

To view the section of the map with the registrants:

The records in the Registr table now have links from the Address column to the specific streets named in the Street column of Dcwashes. These links allow you to see where these customers are on the map of Washington DC. Now, when you do selections among the registrant records, based on the contents of other columns, the results can be displayed geographically on your map.
Suppose you wanted to know which customer was represented by a particular symbol:

1. From the Main Toolbar, click the Info button.
2. Position the cursor over any symbol and click. MapInfo displays an Info tool window that contains the information on the selected registrant. Click in the Info tool window and scroll through the data.

Congratulations, you've put data on the map. Choose File > Save Registr Table in Lesson Folder 6 and Close All before moving onto the next lesson.
Lesson 6: Selecting

In this lesson, we will practice selecting records from a MapInfo table. We will manually select records from a map using selecting buttons (on-screen selecting). We will also select by directly querying the database table. This will allow us to filter the database for records that meet a certain condition.

The tables that you use with MapInfo can be quite large. This being the case, very often there is a need to work with a subset of a table. MapInfo provides a number of ways to do this. There are tools you can use to select data from your maps (on screen selecting) as well as the ability to query the tabular data to extract only those records that meet some specified condition.

In this lesson, you’ll use the sample bicycle Registrants table and the Washington DC street map to complete the following:

- Select objects by using the Select, Radius Select, Boundary Select, and Marquee Select tools.

First, we’ll open the registrants and DC street map table as maps.

1. Choose File > Open Lesson 6 Folder.
2. Choose Registr and while holding down the Ctrl key, choose Dcwashes.
3. Click Open. Both maps display.
4. To make sure all of the registrants are in view, place the mouse over the map, right click and choose View Entire.

Selections can be made from a Map window by using any one of the Select buttons. This is known as selecting geographically. The other method is selecting by creating a query expression. This is known as selecting based on a specific data attribute.

Selecting Geographically

Let’s start by experiment with the Select button.

The Select Button is used to select objects one at a time. Simply click on an object or record to select it. To select multiple records, click on them one at a time while holding the Shift key down.

Always keep in mind that a selection is a temporary table. After making a selection, you are then able to use it in a map, create a graph of it, browse it, or
perform other analysis on it. Most of MapInfo’s capabilities can be used on a selection or on an entire table.

You’ll use the Select Tool to select objects from a Selectable layer. It is the default tool and displays as an arrow when positioned over your Browser window, Map or Layout. You can select objects individually or as a group.

To select objects individually:

1. From the Main Toolbar, click the Select button.
2. Click on one of the arrows. Notice its appearance changes to show it is selected.
3. Click on another arrow. Notice it is selected, but the first one is no longer selected.

To select more than one object:

- Hold down the Shift key and click three arrows. Notice each remains selected.

As the objects are selected on the map, they are also stored as a selection and can be viewed in a Browser window:

2. From the Browse table drop-down list, choose Selection and click OK. The Browser that contains your selections displays.

Click on the title bar of the map to make sure it is active.

To unselect objects individually:

- Hold down the Shift key and click on one arrow. Notice the one you clicked becomes unselected while the others remain selected.

To unselect all objects:

- Click somewhere, not on an arrow.

Notice all registrants are unselected.

To unselect everything that has been selected you can also Click the Unselect All Button.
Also, to unselect a single record or map object Select a selected record or map object, then press <SHIFT> select to unselect it.

Keep in mind, you cannot use the Select tool to select objects from separate layers. For example, you cannot select an arrow and a street from the map at the same time. Objects must reside in the same Selectable layer.

**The Marquee Select Button**

The Marquee Select Button can be used to select objects that fall within a rectangle. Simply click and drag to draw a rectangle. Note that the Marquee box selects from the topmost selectable layer in your map.

1. Click the Marquee Select button.
2. Press the left mouse button, then hold and drag to draw a rectangle.

**The Radius Select Button**

The Radius Select Button can be used to select objects that fall within a specific radius of your starting point.

Using the Radius Select Button:

1. Click the Radius Select button.
2. Press the left mouse button, hold and drag to draw a circle inside the map.

As you draw, notice that the status bar at the bottom of the window displays the radius of your selection circle.

In this example, note that the selection was made from the topmost selectable layer, Registr.

**The Boundary Select Button**

Use the Boundary Select Button to find and select objects within a region.

Using the Boundary Select Button:

1. Click the Boundary Select button.
2. Click inside a state, but not on a customer or city.

In this example, MapInfo selects all records from Registr within the given boundary. The Registr table is the topmost selectable boundary layer in this Map window. Therefore, MapInfo will select registrants within a given area.

By using Layer Control to make some changes to the Map window, it is possible to change which table the selection will come from.

By either unchecking the selectable option for the Registr layer, or by reordering the layers so that you can select records from the street layer instead of the customer layer.

The Polygon Select Button

The Polygon Select Button allows you to draw a custom polygon in a map window and then search and choose objects within that polygon.

1. Click the Polygon Select Button.
2. Click in the Map window to begin drawing a custom polygon.
3. Double click with the left mouse button to close the polygon and select the objects that fall within it.

Viewing the Contents of a Selection

To view the contents of a selection, you can create a browse window.

1. Make a selection using any of MapInfo’s Select buttons.
2. Click Window > New Browser Window.
3. Choose Selection from the Browse Tables list and click OK.

Inverting Selections

Use the Invert Selections feature to unselect areas you may have selected and select those that weren't. For example, if you have selected New York State from a map of the United States and choose Invert selection, New York State will be unselected and all other states on the map will be selected.

1. Make a selection using any of MapInfo’s Select buttons.
2. Choose Query > Invert Selection (or you can click the Invert Selection button from the Main Toolbar).

Your selections are now inverted.
Selecting By Query

MapInfo makes finding information and locations easy. You can create subset databases of your information by using the Select function. We will use the Registrants table to select those cyclists that have more than $500 in pledges.

1. Choose Query > Select. The Select dialog displays.
2. Complete the Select dialog: To complete the Select dialog the Select records from table drop-down list, choose Registr. Click on Assist. The Expression dialog displays.
3. To complete the Expression dialog, from the Columns drop-down list, choose Pledges. From the Operators drop-down list, choose > (the greater than sign). Type 500. Click Verify to confirm the syntax of your expression. Click OK to close the Verify dialog. Click OK to close the Expression dialog. The Select dialog redisplays. Make sure the Check the Browser results option is checked.
4. Click OK to select the registrants. MapInfo creates a Browser that contains the selections. Notice that the selections display in both the Registrant map and Browser.

<table>
<thead>
<tr>
<th>Lastname</th>
<th>Firstname</th>
<th>Address</th>
<th>City</th>
</tr>
</thead>
<tbody>
<tr>
<td>VanDenBerg</td>
<td>Bea</td>
<td>1350 M ST NW</td>
<td>Washington</td>
</tr>
<tr>
<td>Sweet</td>
<td>Beth</td>
<td>1915 14TH ST NW</td>
<td>Washington</td>
</tr>
<tr>
<td>Slop</td>
<td>Bill</td>
<td>1708 MASSACHUSETTS AVE NW</td>
<td>Washington</td>
</tr>
<tr>
<td>Smith</td>
<td>Brendan</td>
<td>1 DUPONT CR NW</td>
<td>Washington</td>
</tr>
<tr>
<td>Roche</td>
<td>Ed</td>
<td>1275 K ST NW</td>
<td>Washington</td>
</tr>
<tr>
<td>Potts</td>
<td>Eric</td>
<td>520 14TH ST NW</td>
<td>Washington</td>
</tr>
<tr>
<td>Murray</td>
<td>Greg</td>
<td>1100 22ND ST NW</td>
<td>Washington</td>
</tr>
<tr>
<td>McDermott</td>
<td>Hui</td>
<td>1333 NEW HAMPSHIRE AVE NW</td>
<td>Washington</td>
</tr>
<tr>
<td>McDermott</td>
<td>Jake</td>
<td>1511 K ST NW</td>
<td>Washington</td>
</tr>
<tr>
<td>Lentz</td>
<td>Joe</td>
<td>1795 MASSACHUSETTS AVE NW</td>
<td>Washington</td>
</tr>
<tr>
<td>Hirsch</td>
<td>Kevin</td>
<td>1509 14TH ST NW</td>
<td>Washington</td>
</tr>
<tr>
<td>Messine</td>
<td>Kevin</td>
<td>1155 21ST ST NW</td>
<td>Washington</td>
</tr>
<tr>
<td>Holpin</td>
<td>Kim</td>
<td>1036 R ST NW</td>
<td>Washington</td>
</tr>
<tr>
<td>Graham</td>
<td>Laura</td>
<td></td>
<td>Washington</td>
</tr>
<tr>
<td>Grab</td>
<td>Laurie</td>
<td>750 17TH ST NW</td>
<td>Washington</td>
</tr>
</tbody>
</table>

Saving Selections and Queries

If you want to run the same query statement in later sessions because your data changes and you need to keep updated lists, you can save your query statements. MapInfo offers three ways to do so:

1. Create a Query table by choosing File > Save Query.
2. Create a query template by choosing Save Template from the Select dialog.
3. Saving the Query to a Workspace by choosing File > Save Workspace.

You can also save the results of a query by saving a copy of the results to a table by using File > Save Copy As.

Congratulations, you've completed this lesson! Choose File > Close All before moving onto the next lesson.
Lesson 7: Labeling your Map

In this lesson, we'll use MapInfo’s labeling features to create map labels. We will also learn how to put titles and other descriptive text on our maps. Many times, you may need to display values or the names of streets, cities, countries, or other geographic features on the map.

Creating Labels

There are several ways to assign labels to a map. Let’s start interactively by using the Label button from the Main Button Pad to label our state capitals map.

1. Choose File > Open Lesson 7 Folder. From the Open table dialog choose States and Statecap.
2. Click Open.
3. Click the Label button.
4. When you click on a map object with the Label button, MapInfo will place a text label near that object.
5. MapInfo labels are obtained from the underlying data associated with the map objects, (the default is to use the first column in the table).
6. Using the Label button, click on several map objects.

Automatic Labeling
1. The Label Options dialog box accessed from the Layer Control dialog box allows you to control various settings for the labels, including the font that is used.
2. With your mouse pointer inside the map, right-click and choose Layer Control.
3. The label column of check boxes turns labels on and off for each layer.
4. Check the label box for the Statecap layer (underneath the label icon). Click Label.
5. The Label Options dialog box displays.
6. The Label button allows you to control settings for the labels of each layer.
7. Choose a new font for your labels and click OK.
8. Click OK.

**Editing Labels**

You may need to edit a label. You may wish to move a label or you might need to change the font, color, or size of the label. It is even possible to change the text of the label.

To move a label:

1. Choose the Select button from the Main ButtonPad.
2. Click and hold on a label, and drag the mouse.

To edit an existing label:

3. With the Select button, double click on a label.

The Label Style dialog displays.
Experiment with changing some of the settings for the label.

Removing Labels

To remove labels:

1. Select a label(s) using the Select button.
2. Press the Delete key on the keyboard.

Or

o Choose Edit >Clear.

Saving Labels

To save labels, save a workspace. The workspace will save your desktop configuration (your map, graph, and browse window layout) and labels.

2. Type a name and click OK.
If you close the table you are labeling or shut the window without saving the labels, MapInfo will ask if you wish to save a workspace.

Creating Titles

To create a title, use the Text Button from the Drawing ButtonPad.

Before you can add the text to your Map window, you must have an editable map layer. An editable layer accepts new map objects when they are drawn in the map and allows you to modify existing map objects by deleting, reshaping, and changing the style of them.

Let's make the Cosmetic Layer editable. As discussed in the User's Guide, the cosmetic layer is placed in every Map window and cannot be reordered from the top or removed. Think of it as a piece of transparency laid over top of your base maps. Use it for creating test map objects and placing additional annotation to the map that you cannot create through labeling, such as titles.

1. Click the Layer Control button.
2. Select the Cosmetic Layer.
3. Check the box underneath the Pencil column.
4. Click OK.

With the cosmetic layer editable, you can add, delete or modify its contents. The Status Bar indicates which layer is editable:

1. Click the Text button on the Drawing ButtonPad.
2. Click in the Map window where you wish to position your title.
3. Type any phrase you want to display as a title.

Now that you have a title in your cosmetic layer, you might want to save it. There are two ways you can save what you have created in the cosmetic layer:

1. When you save a workspace, objects in the cosmetic layer are saved.
2. It is possible to save the objects (text or otherwise) from the cosmetic layer into a new table. You could then re-use the table with different maps.

Congratulations, you've completed this lesson! Choose File > Close All before moving onto the next lesson.
Lesson 8: Working with Layouts

With MapInfo’s Layout Window you can create professional looking maps. We’ll explore creating a legend and printing single and multiple windows on a single page. The Layout window is an area where windows are organized for output to an output device such as a printer or to a file. The elements on each page can be maps, browsers, graphs, legends, text, or other graphic objects. Windows (maps, browsers, and graphs) are represented by rectangular frames that you can size and position. The border and fill of each frame can be modified. You can also draw lines, figures, or choose text that enhances the clarity or aesthetic quality of your output.

After performing analysis on your data and creating the final maps, browsers, and graphs, you may desire to arrange several different windows onto a page and print it.

Before we use the Layout Window, let's open some maps.

2. Click Open.

A map of the layers displays.

Creating Legends

First, we’ll create a cartographic legend. A cartographic legend is a simple way to add additional annotation to a map. It provides a means to display cartographic styles as well as theme legends for an active map window.

A cartographic legend will display cartographic and thematic frames that include a legend title, subtitle, and map layer styles. A cartographic legend can be placed in a layout window or output using MapInfo’s OLE capability.

Let’s start by creating a legend for our map.

1. Choose Map > Create Legend.
2. The dialog Create Legend - Step 1 of 2 displays. Click Next to show all of these layers in the legend.
3. The dialog Create Legend - Step 2 of 2 displays.
4. Use this dialog to change the title of the legend window or change graphic descriptions for each layer. This information can always be modified at a later date. For now, accept the defaults and click Finish.
The legend displays. Notice, as with other types of windows, the Legend now displays in the Menu bar.

Once the cartographic legend has been created, it can be edited if necessary. Edits include adding layers, changing the cartographic legend’s title, layer descriptions, and window orientation.

Let's change the cartographic legend's window orientation. A cartographic legend can be displayed within a window using a portrait orientation or landscape orientation:

Let's change the current orientation to landscape.

1. From the Legend window, choose Refresh Legend.

The Refresh Legend dialog displays.

2. Press Landscape.
3. Click OK.

To save a legend, you must save a workspace.

Now that our map and legend are complete, let's discuss printing with MapInfo. We will focus our discussion first on page setup and single window printing.

**Printing a Single Window**
Before working with MapInfo's Layout Window, be sure you have set the printer options as you need them. Remember, you can also print any Map, Browser, or Graph window by choosing File > Print. The contents of the active window is printed.

When printing a window, you can change the number of copies, pages to print, or print quality. You can also have MapInfo print to a file by setting your printer driver appropriately.

To set up your first Layout window:

2. Click OK. A Layout window displays. It contains the Bikemap workspace.

Let's enlarge our layout:

1. From the Main Toolbar, click the Zoom-in button.
2. Place it over the white layout page and click two times.
Adjusting the Layout

Next, we’ll adjust the frame’s position in the Layout window:

1. From the Main Toolbar, click the Select button.
2. Click on the Bikemap Map in the Layout window. Its frame and handles display.
3. Drag it down the page a bit.

Now that we have a map in the Layout window, we will open a Browser and add that to the Layout window.

1. Choose Window > New Browser Window. Choose the Biketour to display the Biketour Browser. To add the Browser to the Layout window, we must add a frame to contain the Browser.
2. Click on the Layout window's title bar to make it active.
3. Click the title bar of the Drawing Toolbar and drag it so it displays and is active.
4. From the Drawing Toolbar, click the Frame button.
5. Move the cursor over the Layout window, above the tour map. On an empty section of the window, click and drag the cursor diagonally, creating a dotted box.
6. Release the mouse button. MapInfo displays the Frame Object dialog. Make sure that the Biketour Browser is listed in the Window drop-down list. Click OK.
7. MapInfo places the Browser in the frame.
Next, size the frame to fit the browser:

1. Click on the Select button from the Main Toolbar.
2. Click the Browser frame.
3. Drag the handles to allow the frame to fit the browser.

To align the browser:

1. Shift-click the map to select it.
2. Choose Layout > Align Objects. The Align Objects dialog displays.
3. From the Horizontal drop-down list for selected objects, choose Align Center. Click OK. The Layout window displays.
You could also add the legend to your layout window by using the same method.

**Adding Text to your Map**

Next, we'll add some text to describe your map and browser:

1. Maximize the Layout window by clicking the window's Maximize button.
2. From the Drawing Toolbar, click the Text Style button \[ \text{A}^{\text{p}} \] The Text Style dialog displays. From the Font size drop-down list, choose 36 point, choose bold and red.
3. From the Drawing Toolbar, click the Text button \[ \text{A} \] and click under the Browser frame in the Layout window. Type the title: 2000 Bike Tour.

**Moving Items in the Layout**

Let's place the title above the Browser. It's easy to move text, objects, or frames in the Layout window.

1. From the Main Toolbar, click the Select button \[ \text{arrow} \] .
2. Click anywhere on the text you have just typed to select it, hold down the mouse button and drag the text to the middle of the Layout window. To
move any object in the Layout window (including frames), click on it with the Select tool, hold down the mouse button, and drag the object.

3. Release the mouse button, and MapInfo moves the text in the same way.

Finally, you can send this Layout window to a printer:

1. Choose File > Print. Make sure that your output is directed to the output device of your choice. (If your output is not directed to the correct output device, you can change these settings by using the File > Printer Setup option.)
2. Click OK.

Throughout this lesson we have been polishing the output for final printing and presentation. Note, however, that Layout windows are linked to all the other windows they contain. If you make a change to a Map window, that change is immediately reflected in the frame containing that window. The same is true for changes made to a Browse or Graph window, any frames containing these windows will also be changed. You can see how the objects in the Layout window change by performing some simple operations on the other Windows. For example, you can zoom in on a country and then see the frame containing the map automatically updated.

Also, to save your work in the Layout window you’ll need to save it in a workspace.

To close your work choose File > Close All. Congratulations, you are now ready to move on to the next lesson.
Lesson 9: Using Thematic Maps for Analysis

Thematic mapping allows you to see patterns and trends in your data. You can watch them develop in the variety of thematic maps MapInfo allows you to construct. You can view your data by using any MapInfo thematic template or alter the defaults to create your own.

In this lesson, you will practice thematic mapping to complete the following:

- Create a Point Range Thematic map to show graphically the amount of pledges by each registrant in our sample database.
- Create a Graduated Symbols map to show registrants according to the size of their pledge.

Creating a Point Range Thematic Map

We begin our exploration of thematic mapping by creating a ranged thematic map. In this type of map a single color or style of a symbol represents a range of values. First, we'll open the Registrant and DC Street maps.

1. Choose File > Open Lesson 6 Folder. The Open Table dialog displays.
2. Choose Registr and while holding down the Ctrl key, choose Dcwashs.
3. Click Open. Both maps display.
4. To make sure all registrants are in view, right click over the map and choose View Entire Layer.

You are now ready to represent each registrant by a symbol that represents the size of their pledge.

1. Choose Map > Create Thematic Map. The first Thematic Template dialog displays.
2. Next, select the type of thematic map you wish to create. MapInfo allows you to create seven different types of thematic maps. Each type has its own purpose and unique qualities.

   The types of thematic maps include:
   - Ranges: Each color represents a range of numerical values.
   - Bar Charts: A bar graph is placed over each object being shaded.
   - Pie Charts: A pie chart is placed over each object being shaded.
   - Graduated Symbol: Symbols of different sizes are used to represent the magnitude of the data. That is large symbols represent large values and small symbols represent small values.
- Dot Density: Dots are placed on the boundary map so that the total number of dots represent that region's data value.
- Individual: Each unique value is given its own color or symbol.
- Grid: A surface thematic interpolating point data over a region.

You also need to select a thematic template. A *thematic template* contains thematic map settings, such as color choice, range method, and legend settings. These templates are to be used during current and future sessions. A template must be chosen each time a thematic map is created.

For each type of thematic map, there are a variety of predetermined templates to choose from. In the case of ranges or individual value thematic maps, you need to know the type of graphic object you wish to shade. These types of thematic maps have templates for points, lines, and region type objects.

3. Click on the button labeled Ranges and choose the template Point Ranges Default. Click the Next button.
4. The second Thematic dialog displays allows you to specify the table you are shading and the field you will shade. The data can either be in the table that you are shading, or it can come from another table. The data we are using is in the same table. From the Table drop–down list, choose Registr. From the Field drop–down list choose Pledges. Click on the Next button. The third Thematic dialog displays.

5. This dialog previews the ranges it has calculated for population. We’ll change the map legend to 5 ranges. Click Customize Ranges, change the number of ranges to 5 and click Recalc. Click OK.

![Customize Ranges dialog]

6. Click OK. The shaded map and its legend that explains the shading display.
You can save this template we have altered by assigning 5 ranges and use it again with different data.

1. Choose Map > Modify Thematic Map.
2. Click SaveAs, type PledgeRanges for the template name and click OK. This new template will now display in the first Thematic dialog.
3. Click OK.
You can save this template we have altered by assigning 5 ranges and use it again with different data. All thematic templates can be modified, deleted, and new templates can be created.

1. Choose Map > Modify Thematic Map.
2. Click SaveAs, type PledgeRanges for the template name and click OK. This new template will now display in the first Thematic dialog.
3. Click OK.

Using Graduated Symbols

So far we have used thematic maps to describe important relationships based on area. However, MapInfo also allows you to describe relationships based on points or lines. Next, we'll use a graduated symbol map to distinguish registrants by the size of their pledge.

First, you'll have to clear the map:

1. From the Main Toolbar, click the Layer Control button \(\text{Layer Control}\). The Layer Control dialog displays.
2. Highlight RangesbyPledges, click Remove, and click OK. Click Discard.
3. Click on the Legend Window's Close button to close the window.

Next, we'll assign proportionally sized symbols to each registrant based on their pledges.

1. Choose Map > Create Thematic Map.
2. From the first Thematic dialog, click on Graduated, choose Graduated Symbol Default and click Next.

1. From the second Thematic dialog, from the Table drop-down list, choose Registr from the Field drop-down list, choose Pledge and click on Next.

2. The third Thematic dialog previews the symbol sizes. Choose settings and we'll set the size of the largest symbol greater than or equal to 500. The others will recalculate accordingly. Click OK.

3. Let's change the legend a bit. Choose Legend and set the title to Registrants According to Pledge Amount. Click the Text button and check Italic and Bold. Click OK. Click OK again to display the map and legend.

Each registrant symbol is now sized according to the size of their pledge.
Finally, let's create a legend to reflect all layers of the map.

1. Choose Map > Create Legend.
2. Click Next at the Create Legend dialog to include a legend for all the layers.
3. Click Finish to use the default settings for the legend.

The new legend window with all the layers represented displays.

To save a thematic map, simply save it as a workspace.

Congratulations, you have completed this lesson. Choose File > Close All before moving onto the next lesson.
Lesson 10: Redistricting

Redistricting is a powerful feature designed to help you manage territories and districts efficiently and easily.

In this lesson, you'll use the sample States and Us_custg maps to complete the following:

- Assign customers to existing districts.
- Reassign customers to new districts.

Assigning Customers

First, we'll open the Us_custg and States tables as maps:

1. Choose File > Open Lesson 10 Folder. The Open table dialog displays.
2. Click Us_custg and States.tab while holding down the Ctrl key. Click the maximize button. The United States and Us_custg map display.

Potential customers in the US are represented by a purple star. Most of our potential customers in our Us_custg table have already been associated with a specific sales territory depending on their location, (N, E, C and W).

However, there are a few customers that do not have a territory. We will use the Redistrict Window to assign them to a specific territory.
2. Complete the Redistrict dialog as shown in the following figure:

3. Choose Us_custg from the Source table drop-down list.
4. Choose Terr from the District Field drop-down list. The territory will serve as the basis for our grouping of customers. Choose Sum(ORDER_AMT) from the Available fields box. Click Add to add the Sum of the order amounts for the district to the fields that will display in the Districts Browser. We already know those customers with the largest orders may be our largest customers.
5. We want to add this field so that we can see order amounts change as we redistrict.
6. Click OK.

MapInfo alerts you that the Terr field has fewer than 4 characters. If your districts were complex, this may be a problem. For our sample, it isn’t a problem, so click Continue.

When finished, the map and its Districts Browser display.

- Click the title bar of the Browser and drag it to the side of the map so you can see both.

Notice each customer is represented by the symbol for his associated territory.
The sum of the order amount is displayed along with the number of customers in each territory. Each territory is labeled with its name from the Us_custg table.

However, one territory is denoted by **. This group of customers has not been assigned to any territory.

Let’s assign a few of them now.

First, we’ll need to display them by using some sort of symbol:

1. In the Districts Browser, click on the symbol column for ** (the column following 18). The Symbol Style dialog displays. From the Symbol drop-down list, choose the cross. From the Color drop-down list, choose red. From the Size drop-down list, choose 24. Click OK. The map re-displays, with those unassigned customers marked by a large, red cross.
2. Next, we need to assign these customers to a territory. Start with the West coast. Click the Map’s title bar to make it active.
3. From the Main Toolbar, click the Zoom-in button and click on California.
4. In the Districts Browser, click on the box preceding W to target the west territory.
5. Click the title bar of the Us_custg, States Map to make it active.
6. From the Main Toolbar, click the Select button.
7. Hold down the Shift key and click on two or three customers marked by the cross. As they are selected, notice how the data in the Districts Browser changes to reflect the customers being assigned to the W territory. You can see the impact their addition has on the sum of orders and count for the W territory.

However, these customers are not permanently assigned until you say they are. The Districts Browser gives you the ability to experiment with various scenarios without making any final changes.

If you decided you didn’t want these customers to be added to the W territory, you could see how they might impact the Central territory:

- In the Districts Browser, click the box preceding the C territory. The customers, since they are still selected, are now reassigned to the Central territory. Again, notice how the change affects the sum order amount and count fields.

To make these objects permanently part of the Central territory:

- Choose Redistrict > Assign Selected Objects. Those customers will be permanently assigned to the central territory once you save your table.

You could then use the same procedure to assign customers marked by a cross to other territories.

**Adding and Deleting Districts**
Redistricter also allows you to easily create or delete existing territories. For example, you could assign those unassigned customers to a Miscellaneous territory.

To add a district:

1. Click the title bar of the Districts Browser to make sure it is active.
2. Choose Redistrict > Add District. A new district is added to the Districts Browser. Click the box preceding this district. We will now assign some customers to the new district.

While pressing the Shift key, click on other customers marked by the cross.

Notice that these customers are now part of the new district. Again, these changes are not final until you assign them the objects (Redistrict > Assign Selected Objects).

Congratulations, you have completed this lesson. Choose File > Close All before moving onto the next lesson.
Lesson 11: Object Creating and Editing

Drawing and editing tools allow you to draw and modify objects on your map in addition to performing powerful geographic analysis. We'll cover creating a new map, using the drawing toolbar, snap to node and tracing with autotrace,

Labeling the Map

First, we'll open the Bike route map:

1. Choose File and Open Lesson 11 Folder.
2. Choose Biketour.
3. Right click over the map and choose View Entire Layer.

First, let's label the map and make the Cosmetic Layer Editable:

1. Choose Map > Layer Control. The Layer Control dialog displays.
2. Click on the Autolabel box.
3. Click on the Cosmetic Layer, click Editable and click OK. The map with its street names displays.

Drawing on the Map

Next, we’ll experiment with drawing on your map. Let’s draw some lines that might represent some alternate routes during the race.
1. From the Drawing Toolbar, click the Line button.
2. Position the cursor over any highway. Click, drag, and release on another highway.
3. To know how long a linear object is while drawing it, press the Distance button found in the Main Button Pad prior to the use of the Line button. The distance of the object will be shown in the Ruler window.

Let’s make the line a railroad route to denote the railroad crossing on our bike tour.

1. From the Main Toolbar, click the Select button.
2. Click on the line. The Line Attributes dialog displays.
3. Click the Line Style button.
4. Choose the railroad track style, red for color and a slightly wider width.
5. Click OK and click OK at the Line Attributes dialog. The line displays with our new style.

Next, we’ll draw some arcs:

1. Reset the line style first, click the Line Style button and choose a black line.
2. From the Drawing Toolbar, click the Arc button.
3. Position the cursor over a road. Click, drag, and release the arc. Draw another arc anywhere on the map.
There are nine drawing tools on the Drawing ButtonPad. These tools allow you to draw and modify objects on your map. You can also use these tools to customize the colors, fill patterns, line types, symbols, and text on the map.

Next, we’ll draw a rectangle to indicate a populated area of the race:

1. From the Drawing Toolbar, click the Rectangle button.
2. Position the cursor over a State Highway. Click, drag and release the rectangle.

If you want to change the style of the rectangle:

1. From the Main Toolbar, click the Select button.
2. Double-click on the rectangle. The Rectangle Object dialog displays.
3. Click the Style button. Choose N as the Pattern.
4. Click OK and OK again.

The rectangle displays transparently.

Creating Map Objects

Next, we’ll create some other types of map objects.

First, clear your drawings from the Cosmetic Layer.

- Choose Map > Clear Cosmetic Layer and click Discard.
Let's add a new route to our table:

1. Choose File > New Table.
2. From the New Table dialog choose Add to current Mapper, uncheck the New Mapper checkbox and click Create. The New Table Structure dialog displays.
3. In the Name box, type Name and click Create.
4. From the Create New Table dialog, type newtour in the File Name box and click Save.

Now, we'll add a new polygon to the map to represent the alternate tour.

To draw a polygon:

1. From the Drawing Toolbar, click the Polygon button.
2. Draw a polygon anywhere on your map. Click to start it on a road. Move to another road, press S to turn Snap mode on to adjoin the polygon to the borders of the route and click once at the end of each polygon node. Continue drawing the polygon by clicking at each endpoint. Notice as you snap the boundaries the cursor becomes larger and when you click, the corners snap to the existing route.
3. Double-click to end and close the polygon. When you are finished, press S to turn Snap mode off.

Let's associate information with your new polygon:
1. From the Main Toolbar, click the Info button.
2. Click on one of your objects.
3. Click in the Name field in the Info tool window and type a name you could use for the area such as Novice Rt. That name is now associated with your new polygon.
4. Click the Info Tool window Close button.
5. Click the Info Tool, click on the polygon you just associated with the route and the window redisplays with the Name as the Novice Rt.

**Editing the Map**

Finally, we'll edit some of the objects you have drawn. First, close the Info tool window by clicking its Close button icon.

1. From the Main Toolbar, click the Select button.
2. Click the polygon you drew. Handles display around the polygon.
3. Choose Edit > Reshape.
4. Click on a node and drag it to the new position and release to change the polygon’s shape.

The polygon reshapes to the new position.

Finally, we'll smooth the polyline lines so they curve:

1. From the Main Toolbar, click the Polyline button and draw one anywhere on your map.
2. Click on the Select button and click on polyline to select it.
3. Choose Objects > Smooth. The sharp edges of the polyline become smooth.

**Autotracing**

Use MapInfo’s Autotracing feature to easily trace borders; even those made up of many nodes.

First, let’s remove the Newtour layer and make the Cosmetic Layer editable:

1. Click the Layer Control button. The Layer Control dialog displays.
2. Highlight Newtour and click remove and click the Editable box for the Cosmetic Layer.
3. Click OK.

Now, we’ll trace the northern borders of the route:
• Press the S key to turn snap on.

You may find that you need to trace objects on your map exactly. For example, a cable may need to trace streets, or you may need to trace the border of a region in order to create an adjacent region. This is not a difficult process with MapInfo because MapInfo has a Snap to Nodes feature. The Snap feature makes it easier to trace an object or objects on a map, such as several streets in succession.

Pressing the letter ‘S’ on the keyboard turns on the Snap feature. (Snapping works with all of the tools except the Grabber Tool, the Drag Map Window Tool and the Text Tool.) The Status Bar indicates when Snapping is turned on.

When the Snap feature is turned on, the mouse pointer is “pulled” to the nodes of other selectable objects. (You may think of the nodes as being magnetic). If the cursor gets close to a node, a cross hair appears. This indicates that the cursor has snapped to that node. If you click, the new node will be placed at the same coordinates as the node that you have snapped to.

To use Autotrace, Snap mode must be turned on.

1. Click the Polyline button
2. While holding down the Shift key, click to trace the top borders of the route. As you click on the borders, notice they grey as they are traced.
3. Double-click to end the tracing. Let’s display our border.

First, you’ll need to save the traced border from the Cosmetic Layer to a new table.

1. Choose Map > Save Cosmetic Objects.
2. Choose Save for New.
3. Title the layer Northrt and save again.
4. Click the Layer Control button.
5. Highlight Biketour and click remove. Click OK. The new traced border displays.
Congratulations, you have completed this lesson. Choose File > Close All before moving to the next lesson.
Lesson 12: Buffering

Buffering is a powerful proximity analysis tool. Since buffers are regions, you can search for objects inside of them. When creating a buffer you control the size or radius of the buffer. For example, you can use MapInfo to create a 15-mile buffer around all your retail outlets. Then, you can select all the records from a point file (perhaps competitors’ stores or your own customers) that are located within the buffer.

In addition to selecting objects within a specified radius of one object such as a city, MapInfo also makes it easy to select objects within a radius of other objects. For example, we'll use a sample customer database together with both the States and City_125 maps to find out how many cities are within 50 miles of some of your Florida customers.

First, you’ll need to create a buffer around those customers and then use the Boundary Select tool to select objects (cities) within the buffer range.

We'll open our customer tables and display them with the States map.

1. Choose File > Open Lesson 10 Folder. The Open Table dialog displays.
2. Click on States.tab and Ctrl–click on Us_custg.tab. Click Open.
3. Click the maximize window button.

A full screen United States and customer map displays.

You’ll also need to move the map and zoom so we can see Florida:

1. From the Main Toolbar, click the Grabber button. Place the hand on the map and move the map until Florida is in full view.
2. From the Main Toolbar, click the Zoom-in button. Place the cursor on Florida and click twice. Florida is in full view.

To make the customers easily identifiable, let’s change their symbol and color:

1. From the Main Toolbar, click the Layer Control button. The Layer Control Dialog displays.
2. Click on Us_custg and click on Display. The Display Options dialog displays.
3. Click Style Override and the symbol box. The Symbol Style dialog displays.
4. From the Symbol drop-down list, choose the cross.
5. From the Color drop-down list, choose red and choose 24 pt as the size.
6. Click OK at the Symbol Style dialog and click OK at the Display Options dialog.
7. We’ll also need to make the Cosmetic Layer Editable. You remember the Cosmetic Layer is the top transparent layer where we draw objects, in our case, buffers. With the Cosmetic Layer highlighted, click the Editable box.

8. Click OK. The map re-displays with customers represented by a red cross.

Next, using the Boundary Select tool, we’ll select the customers within Florida that we want to put a buffer around.

1. From the Main Toolbar, click on the Boundary Select button.
2. Click inside Florida (not on a customer).

MapInfo selects each of the customers in Florida. To create the buffer around the customers:

1. Choose Objects > Buffer. The Buffer Objects dialog displays.
2. In the Value Box type 50. Choose One Buffer for each object.
3. Click OK to initiate the process.
The Status dialog displays, and the map displays with the buffers drawn around the customers. To get a better view of our customers and buffers, we’ll change the buffer symbol style:

1. Choose Options > Region Style. The Region Style dialog displays.
2. From the Fill Pattern drop-down list, choose N for no fill and click OK. The Buffers display as transparent circles around the customers. Click in the water to deselect the buffers.

To get a better look, we’ll turn the customer display off and leave only the buffers:

1. From the Main Toolbar, click the Layer Control button. The Layer Control dialog displays.
2. Click on Us_custg, click on Remove and click OK. The map re-displays with only the buffers.

Next, to see which major cities fall within a 50 mile radius of some of our customers, we also have to open our City_125 table.

1. Choose File > Open Table. The Open Table dialog displays.
2. Double-click on the City_125.tab file. The cities and buffers display as shown in the following figure.
Next, we'll select those cities in Florida within a 50 mile radius of our customers.

1. From the Main Toolbar, click on the Boundary Select button.
2. Click within the buffer area on the bottom left of Florida (be sure not to click directly on a buffer or city. Click inside the buffer). Cities within the buffer are selected.

Finally, we'll display those cities selected in their own Browser:

2. From the Browse table drop-down list choose Selection and click OK.

The Browser that contains each of the cities within 50 miles of your Florida customers displays.

If you had 100 cities to select from, you can easily see how buffering can save time.
Congratulations, you have completed this lesson! Choose File > Close All to close this session before you move onto the next lesson.
Lesson 13: Integration Made Easy

MapInfo integrates with your other software applications.

Using your high quality MapInfo maps in your other publishing applications is easy. You can simply copy and paste them or actually build MapInfo maps while in your word processing or spreadsheet applications. You can also use Microsoft Access files directly in MapInfo. Map your Access data easily, edit it in MapInfo and use it again in Microsoft Access.

In this lesson we'll copy a map to an OLE program such as Microsoft Word and Embed a MapInfo Map in an OLE program such as Microsoft Word,

Saving a Window as a Graphics File Format

An option for creating output is to save a window into a graphic file format. MapInfo can capture a window into any of the following formats: Windows bitmap, Windows metafile, Windows Enhanced Metafile, JPEG Interchange Format, Portable Network Graphics Format, Tagged Image File Format, TIFF CMYK and Photoshop 3.0 format. Graphics files in these formats can easily be incorporated into most word processors, spreadsheets, presentation programs, and graphics packages.

1. Choose File > Open. Select the Biketour, Trainrt, Trainrt2, Reststop maps. Open the File menu and choose Close All.
2. Click Open.

To save a copy of this window as a graphic file:

1. Choose File Save Window As.
2. Type the file name Bikemap.
3. Make sure that the Save as Type pop-up list indicates the format you desire. Let's specify Windows Bitmap.
4. Click Save.

Copying a Map

Next, we'll copy a previously created into another OLE program such as Microsoft Word.

1. Choose Edit > Copy Map Window.
2. Start your other OLE program. From your other program, choose Edit > Paste.

The map displays in your other application.
Embedding a MapInfo Map

You can also embed a MapInfo map directly in an OLE container application such as Microsoft Word or Corel Draw. Embedding gives you access to a "mini" MapInfo program where you can create, display and edit a map for presentation, reporting or publishing.

First, close MapInfo. Then, from within your OLE container application such as Microsoft Word or Corel Draw:

1. Choose Insert Object.
2. Choose MapInfo 6.5.

The embedding program becomes active.

1. You can now use the "mini" MapInfo program to create or import a MapInfo map within Microsoft Word or any OLE container application.
2. Choose Table > Open.
3. From the path \MapInfo\Data\Tut_data\Tut_Usa\USA\DC choose biketour. A portion of the bike tour map now displays in your program.
4. From the "mini" MapInfo program, choose Map > View Entire Layer. The entire map displays in the frame.

When a map is embedded you have the ability to edit it. When you right click on the map, a shortcut menu will display. This menu provides access to some commonly used menu items in the application the map is embedded in. Also included is access to the MapInfo map object.

For example

1. Right-click on the embedded map.
2. Choose MapInfo Map Object to Open.

A MapInfo Map in Document screen will display. At this point you can change the map’s zoom, layer control configuration, create and modify thematic maps, and find.
To close the MapInfo Map in Document screen:

If you doubled clicked on the map and want to return to the document, just click outside of the map object but within the document.

  - Choose File > Exit and Return to Document.

**The Drag Map Window Button:**

It is also possible to drag and drop a Map window directly from MapInfo into another application. To do this you need to have MapInfo and the other application both visible on the screen at once.

Select the Drag Map Window button, and click and drag from inside the Map window to the other application. Once over the other application, release the mouse button. (Releasing the mouse button is the "drop" of drag and drop.)

You can also use the Drag Map Window tool to drag a map into MapInfo itself. The result of doing this is the same as the Map > Clone View command.

Congratulations, you have completed all the lessons. You are now ready to work on your workshop requirements for this course.